US Broker
* HTS Automation Enhancements – Release Notes
* This release focuses on optimizing performance, reducing technical debt, and improving stability within the HTS Automation module and related UI components. The enhancements include refactoring core logic, eliminating redundant code patterns, resolving memory leaks, and improving data mapping and UI behavior during entry initiation workflows.
* **Code Refactoring & Log Optimization**
* Refactored repetitive logic across HTS modules to improve code maintainability and readability.
* Removed unnecessary and sensitive log outputs, including environment variables and Redux store data, to enhance security and performance visibility.
* Ensures cleaner debugging information and reduced console noise for developers and testers.
* **Memory Leak Analysis & Resolution**
* Conducted a detailed **Memory Leak Analysis**
* Identified and fixed leaks caused by uncleaned timers, event listeners, and global state references.
* Result: Improved browser performance and eliminated potential crashes during prolonged sessions.
* **Removal of Anti-Pattern and Deprecated Imports**
* Removed direct imports of legacy libraries \(`underscore`\) and replaced them with standardized lodash modules.
* Refactored components relying on lodash functions to ensure consistent import patterns and minimized bundle size.
* **Entry Summary – Core Data and Child Item Enhancements**
* Replaced legacy `ENTRY` references with standardized `CORE_DATA` for weights and related computations.
* Enhanced the **Entry Summary** workflow to automatically add **child HTS line items** upon job initiation.
* When a shipment is created from intake and the user clicks **Start Job**, the system now auto-populates child HTS items.
* If line items already contain child items \(e.g., Target\), duplication is prevented.
* Improves data consistency and automation in HTS mapping and classification workflows.
ES Broker
New Import Process for Spain
Overview
The new import process for Spain has been successfully implemented, significantly expanding the platform’s operational and commercial capabilities within the Spanish market.
Through collaboration with our strategic partner, Tudefrigo, KlearNow will now be able to manage and process imports into Spain end-to-end, integrating all customs and logistics workflow stages.
Enhancement Details
- New national import flow:
Integration of the Spanish customs process into the platform, including document management and data validation for import declarations.
- Collaboration with Tudefrigo:
The partnership with Tudefrigo enables seamless connection between KlearNow’s system and the physical and documentary operations at Spanish ports and customs offices.
- Full visibility:
Customers can now track their shipments in real time, from origin to customs clearance.
- Tracking and reporting:
Includes customized reporting capabilities, providing key insights into import performance (status, timelines, documentation, and operational metrics).
Key Benefits
- Market expansion: launch of import operations in Spain, increasing business coverage and market potential.
- Greater transparency: full traceability and visibility across all stages of the import process.
- Time and cost optimization: integrated workflow that minimizes manual effort and boosts operational efficiency.
- Analytical capability: advanced reporting for performance control, issue tracking, and compliance monitoring.
Next Steps
In the coming weeks, a progressive rollout of the new import flow will take place, onboarding additional customers and expanding operational reach to more Spanish ports.
Impact
This enhancement represents a strategic milestone for KlearNow’s expansion in Europe, strengthening its presence in Spain and reinforcing its position as a comprehensive digital platform for customs
Data & Analytics
1. Major Tariff Update - Section 232 Timber Tariffs
What Changed:
- Updated merchandise warehouse tables to support new US Section 232 Timber Tariffs effective October 14, 2025
- Added four new tariff duty columns for timber-related products
- Modified existing sec232_duties calculation to include new HTS codes
Tables Impacted:
merchandise_wh_table
entry_merchandise_wh_table
customs_merchandise_wh_table
New Columns Added:
sec232_timber_duties - Aggregates all HTS codes starting with 990376
sec232_lumber_duties - Aggregates all HTS codes starting with 99037601
sec232_furniture_duties - Conditional duty calculation for qualifying furniture products (Chapter 94 codes: 9401614011, 9401614031, 9401616011, 9401616031)
sec232_cabinets_duties - Conditional duty calculation for qualifying cabinet products (Chapter 94 codes: 9403409060, 9403608093, 9403910080)
Modified Columns:
sec232_duties - Expanded to include six additional October 2025 tariff codes (99037601, 99037602, 99037603, 99037620, 99037621, 99037622)
Business Value:
- Ensures compliance with current US government tariff regulations
- Enables accurate tracking and reporting of October 2025 timber-related tariff assessments
- Supports detailed analysis across timber, lumber, furniture, and cabinet product categories
2. US Entry Summary Rejections Enhancement
What Changed:
- Expanded US Entry Summary rejections data to include Engine Entry (KN) transaction data
- Previously limited to C360 (KX) shipment data only
Tables Impacted:
us_es_rejections_wh_table
New Data Coverage:
- Engine Entry transaction rejection data from entry schema
- Comprehensive rejection tracking across both C360 and Engine Entry systems
Business Value:
- Provides complete visibility into US Entry Summary rejections across all transaction types
- Enables unified analysis and reporting from a single table
- Table prepared for future Row Level Security (RLS) implementation to support secure external customer access via ThoughtSpot Embedded
Drayage/Visibility/Track & Trace
Track & Trace
Automated Emails
- Disabled automated email notifications from
cs@klearexpress.com in staging environment
- Emails with subject "Please find attached a copy of the Shipments without Estimated Time Of Arrival" will no longer be sent in staging
- Production email functionality remains unchanged
Drayage
DMODAL - Mantain Applied Filters After Bulk Container Update DM
- Filters now persist after performing bulk updates on MBOL containers
- Search and filter states are preserved when submitting bulk container updates
- Only updated containers refresh while maintaining the filtered view
Sales ability to specify accessorial charges in DModal
- Sales users can now specify accessorial charges directly in DModal edit window
- Accessorial charges option is visible when DPartner is assigned
- Charges are fetched from Admin → Master Table → Accessorial Charges
- Selected charges are saved to the container and automatically flow to AR charge list upon gate-in event
- Chassis logic remains unchanged
- Gate-in confirmation includes verification that charges are pushed to AR screen
Billing
New Features & Improvements
Changing Netherlands invoicing address for Netherlands invoices
The address printed on Netherlands Klearnow invoices has been updated to:
Klearnow Netherlands B.V. Julianastraat 30 2012 ES HAARLEM Netherlands NL860343893B01 ap@klearnow.com
This new address will now appear in the KN address section on all Netherlands invoices.
Super Freight Forwareders users access issues
- Resolved access issues for SFF users and team members, ensuring that all relevant users can view invoices and shipments as intended.
- Now, when a user is added as an SFF user type or as a team member of the SFF, they will have the correct visibility for invoices and shipments.
Changes in UK billing invoices for customers
Updated the UK address on 360 invoices to:
Isher House Isher Business Park, Peel Cross Road, Manchester, England, M5 4DT
Added KN VAT number (331948590) on all UK invoices.
Updated addresses for all Netherlands and Spain invoices, and changed the Spain invoice email to ap@klearnow.com.
Intact reducing API calls for AR adjustment
- Reduced the number of API calls made by the AR adjustment API to ensure monthly API usage remains within contract limits, helping avoid additional costs and improving system efficiency.
Fixes & Corrections
AP rate calculation on AR admin chargelist working incorrectly
- Fixed an issue where AP rate calculation was not functioning correctly in the admin chargelist filter.
- The calculation (unit count × rate) now works as expected for all types of charges, including merchant, drayage, and CHB charges.
Wrong customer approved rates coming to AR charges list on gate in trigger
- Fixed an issue where incorrect customer-approved rates were appearing in the AR charges list upon gate-in. Now, only the correct rates are shown as expected.
Drayage invoices wrong amounts going to Intacct on sales approval of invoices
- Fixed an issue where, upon sales approval, customer-approved rates were not syncing correctly to Intacct. Now, all approved rates, including AP rates, sync to Intacct as intended.
Intake
- Enhancing the AI Pipeline
- BASF and other customer improvements
Engine
KlearAssist | AI-Powered Assistant
This is the launch of our new AI-powered assistant, designed to give you instant answers on topics like user management and roles.
Persistent Chat History & Loading
- Always-On History: Your conversations are now saved. You can refresh your browser, log out, or log back in, and your previous chats will be retained.
- Efficient Loading: To maintain fast performance, chat history is loaded in batches of 10. Older messages will automatically load (lazy-load) as you scroll up through the chat pane.
- Personalized Experience: Your chat history is strictly specific to your user profile.
User Onboarding and First-Time Experience
- Feature Introduction: When you visit the landing page for the first time, an introductory tooltip will appear next to the KlearAssist icon: "Meet KlearAssist! Your AI-powered assistant. Ask about user management and roles, and get instant answers." Once you close it, it won't appear again.
- Personalized Welcome: When you open the KlearAssist panel, the first screen will display a personalized welcome with your name and present three suggested questions to help you get started.
Daily Usage Limits and Warnings
- Proactive Warning: You will now receive a warning message when you have 6 daily tokens remaining: "Heads up! You have 6 tokens left today."
- Limit Reached State: If you use all 25 daily tokens, the input field will be disabled. A clear message will be displayed indicating you've hit your daily limit and showing the specific date and time the limit will refresh, based on your local time zone.
Improved Output and UI States
- Time-Stamping: All responses from KlearAssist now include a time stamp so you can track when the answer was generated.
- Enhanced Formatting: Responses are now formatted using markup (like bullets and bolding) to ensure the output is easy to read and aligns with our design standards.
- Loading and Cancellation: For long-running queries, you will see animated loading indicators and a "Cancel Request" button that allows you to abort the operation if needed.
Other Platform Enhancements
Invoices: FFW Name in Company Dropdown
- Easier Selection: In the invoices screen (Visibility 2.0), the company selection dropdown has been updated to display both the company name and its corresponding freight forwarder (FFW) code. This eliminates confusion and makes it easier to select the correct company when searching.
Company Settings: New Toggle in Brokerage Preferences (US)
- New Preference Option: A new toggle has been added to the Brokerage preferences tab for US companies.
- Placement: It is positioned after the "Product ID" toggle and before "Data Aggregate."
- Default Status: This toggle is enabled by default for all existing Importers of Record (IORs).
Data Migration: Enhanced Support for New IORs
- This update streamlines the process for adding new IORs to company structures that have already been migrated to the new Engine.
- Data Integrity: The migration tool now automatically detects the existing, migrated structure, ensuring the new IOR is created and associated with the correct parent customer and sub-customer structure, whether it was an independent IOR or part of a full Freight Forwarder structure.
AI Improvements
Golden 500 Creator - Invoice PDF Extraction Training Generator
Overview
Golden500 Creator is a comprehensive Django-based web application designed to generate synthetic invoice PDFs and validate LLM extraction accuracy. This tool empowers AI/ML teams to create diverse, realistic training datasets by generating invoice variations across multiple professional templates and edge cases. The application provides end-to-end functionality from dataset upload through PDF generation to extraction validation and accuracy analytics.Built specifically for training and testing document extraction systems, Golden500Creator bridges the gap between structured data sources and real-world document variations, enabling robust model development and quality assurance workflows.
Key Features
Multi-Template PDF Generation
- 5 Professional Invoice Templates - HOWE Corporate, ATLAS Proforma, Modern Minimal, Classic Formal, and Tech Sleek designs provide diverse visual layouts for comprehensive training coverage
- Edge Case Variations - Automatically generate realistic document imperfections including rotation, color aging, dust/dirt artifacts, reduced sharpness, and low-quality scans to test extraction robustness
- Batch Processing - Generate thousands of invoice PDFs from Excel datasets with customizable template counts per invoice (1-5 templates)
Intelligent LLM Validation Engine
- 20+ Field Comparison - Comprehensive accuracy tracking across all invoice fields including vendor details, line items, totals, and trade information
- Accuracy Classification - Automatic grading of extraction quality (Perfect, Good, Fair, Poor) with detailed field-by-field analysis
- Session Management - Save, review, and compare validation sessions over time to track model improvements
Robust Data Management
- Excel Integration - Parse structured invoice data from uploaded Excel files with automatic column mapping
- MySQL Database Storage - Enterprise-grade data persistence with proper relationships and binary PDF archiving
- ZIP Archive Export - Download batches of generated PDFs organized by template and variation for easy distribution
Enterprise Security
- Environment-Based Configuration - Secure credential management using .env files with python-decouple integration
- Interactive Setup Script - Guided setup_env.py wizard for secure configuration deployment
- Database Security - Protected MySQL credentials with SHA256 password authentication support
Professional User Experience
- KlearNow Platform Theme - Consistent, modern UI design with responsive layouts for desktop and mobile
- Real-Time Progress Tracking - Live generation progress with intelligent timeout handling for large datasets (supports 30+ minute generation runs)
- Detailed Analytics Dashboard - Visual charts, session history, and downloadable comparison reports
Production-Ready Architecture
- 30-Minute Request Timeout - Handles large-scale PDF generation (2,500+ documents) without connection interruptions
- Scalable File Handling - 50MB upload limits with configurable memory allocation
- Comprehensive Logging - Detailed failure tracking with summary statistics for debugging and monitoring
AI-Driven Standardization of Entry Summary (7501) Extraction
Overview
The new data model and extraction workflow for Entry Summary (7501) documents has been successfully designed and implemented.
Through the integration of advanced Artificial Intelligence (AI) models, the system can now identify, classify, and extract 7501 data with significantly greater accuracy and speed, minimizing the need for human in the loop.
Enhancement Details
- Intelligent Data Schema:
Establishes a unified structure that enables AI to adapt to multiple 7501 formats and brokers without requiring manual configuration.
- AI-Powered Extraction Flow:
The process leverages trained models to automatically detect key fields, relationships, and values across both structured and unstructured document types.
- Automated Validation & Continuous Learning:
AI validates extracted data against predefined schema rules and continuously improves its accuracy based on real-world feedback.
- Intelligent Pipeline Processing:
Fully integrated into the new data pipeline, allowing for high-volume document processing with minimal human intervention.
Key Benefits
- Faster and more accurate data extraction through AI-driven automation.
- Full consistency across different clients, brokers, and document layouts.
- Significant reduction in development and validation time.
- Immediate data availability for dynamic and centralized customer reports.
- Seamless scalability to onboard new countries or document types.
Next Steps
Once the AI-driven pipeline goes live, most 7501 forms received through the platform will be automatically processed and validated, with extracted data made available to customers in real time through configurable reports.
Impact
This enhancement represents a major milestone toward the full automation of the U.S. post-audit customs workflow, establishing Artificial Intelligence as the operational core of the product and reinforcing KlearNow’s leadership in digital customs innovation.
Other
This material is proprietary to KlearNow and intended solely for use with KlearNow's tools, platform, and software. Unauthorized use, sharing, or distribution is prohibited without prior written consent. For legal, financial, or regulatory decisions, consult your own advisors.