The email delivery issue has been resolved. KlearNow emails are now flowing normally, and we are no longer seeing bounced messages. Shipments continue to process as expected. We will continue to monitor the system closely to ensure stability.
Posted Feb 06, 2026 - 10:44 PST
Investigating
Starting around 5:30 AM PST, we identified an issue impacting email delivery through our AWS-hosted email routing service. The issue is not affecting all customers, but a few customers may experience bounced emails.
Shipments continue to be successfully ingested and processed in the KlearNow system, and our validation confirms there is no data loss.
We have an active incident open with AWS and are working with them to restore full email delivery. We will continue to provide updates as more information becomes available.
Posted Feb 06, 2026 - 09:53 PST
This incident affected: Customs Engine, Customs360, Drayage360, and Customs360 Broker Platform.